top of page
Home: Blog2
Writer's pictureAnuj Yadav

How to continue reading lines until there is no more input in Python.

from sys import

stdinlines = stdin.read().splitlines()


It will store all the input in a list. Let us understand it with a Hackerrank Problem.


  1. Objective Today, we're learning about Key-Value pair mappings using a Map or Dictionary data structure. Check out the Tutorial tab for learning materials and an instructional video!Task Given names and phone numbers, assemble a phone book that maps friends' names to their respective phone numbers. You will then be given an unknown number of names to query your phone book for. For each queried , print the associated entry from your phone book on a new line in the form name=phoneNumber; if an entry for is not found, print Not found instead.Note: Your phone book should be a Dictionary/Map/HashMap data structure.

  2. Input Format The first line contains an integer, , denoting the number of entries in the phone book. Each of the subsequent lines describes an entry in the form of space-separated values on a single line. The first value is a friend's name, and the second value is an -digit phone number.After the lines of phone book entries, there are an unknown number of lines of queries. Each line (query) contains a to look up, and you must continue reading lines until there is no more input.Note: Names consist of lowercase English alphabetic letters and are first names only.

  3. Constraints

  4. Output Format On a new line for each query, print Not found if the name has no corresponding entry in the phone book; otherwise, print the full and in the format name=phoneNumber.

  5. Sample Input 3 sam 99912222 tom 11122222 harry 12299933 sam edward harry

  6. Sample Output sam=99912222 Not found harry=12299933

Solution:


# Enter your code here. Read input from STDIN. Print output to STDOUT from sys import stdin n=int(input()) d=dict() for i in range(n):

k,v=input().split(" ") d[k]=v

lines = stdin.read().splitlines() for i in lines:

if i in d.keys(): print(i,"=",d[i],sep="")

else: print("Not found")

52 views0 comments

Comentarios


Home: Subscribe

CONTACT

 Kanpur, India

8299229032

  • twitter

Thanks for submitting!

Home: Contact
bottom of page